Программа Dr View

Video Recorder

Содержание | О программе | TAHA


О программе

VideoRecorder

Назначение программы.

Video Recorder предназначен для записи видео, используя установленные в системе драйверы Video Capture Devices, отвечающие спецификации Video For Windows. С помощью этой программы можно записывать как непрерывное видео, так и одиночные кадры. Video Recorder записывает видео непосредственно в файл, расположенный на жёстком диске компьютера.

Video Recorder является самостоятельной программой, однако может работать под управлением других программных продуктов выпускаемых компанией "TAHA".


Содержание справки

VideoRecorder

Содержание

Запуск программы и выбор устройства

Установка режима мониторинга

Синхронизация MCI устройства

Установка параметров аудио

Выбор параметров источника видео

Выбор формата видео

Установка параметров сжатия видео

Работа с палитрой

Установка скорости захвата видео

Установка таймера захвата видео

Выбор режима захвата

Захват

Установка параметров Video Recorder'a

Использование схем

Специальные элементы управления


Особенности работы с видео

VideoRecorder

Особенности работы с видео.

Video Recorder записывает видео непосредственно в файл, расположенный на жёстком диске компьютера. Поскольку этот файл может быть очень большим (до 2 Гб), предприняты меры для исключения лишних операций копирования.

Video Recorder постоянно держит заранее подготовленный к захвату файл, чтобы уменьшить время, необходимое для инициализации операции захвата. Этот файл имеет автоматически сгенерированное специальное имя. После успешного захвата Video Recorder предлагает просто переименовать этот файл. Если переименование происходит в пределах одного и того же логического диска – длительной операции копирования удаётся избежать.

Максимальный размер файла видео, который можно записать, определяется реализацией Video For Windows и составляет 2 Гб. Однако, к сожалению, ни Video For Windows, ни Video Recorder не контролируют размер этого файла при записи (мы надеемся, что в следующей версии Video Recorder этот недостаток будет устранён), и, если файл превысит максимальный размер, прочитать его будет невозможно.

Размер файла определяется размером кадра, частотой кадров, временем записи и установленным компрессором видео. Например, для видео 512 х 512 х 8 бит без сжатия (= 256 Кб) и без звука, максимальное время записи при скорости 25 к/сек составляет не более 5 минут, при 12.5 к/сек – 10 минут и т.д., при 1 к/сек – около 2 часов.


Запуск программы и выбор устройства

VideoRecorder

Запуск программы и выбор устройства.

Video Recorder можно запустить как самостоятельное приложение (т.е. также как и любое другое приложение Windows) или под управлением другого программного обеспечения TANA (смотрите соответствующую документацию по этому программному обеспечению). В последнем случае заголовок окна Video Recorder имеет форму:

Video Recorder for <Имя_управляющей_программы>.

Окно Video Recorder представляет собой монитор текущего видео на входе (если, конечно, устройство ввода видео правильно установлено и выбрано).

Окно также имеет панель управления, которую можно расположить как больше нравится: прикрепить слева или справа, а также открепить и расположить отдельно. Окно Video Recorder (также как и панель управления) запоминает своё расположение на экране от сеанса к сеансу.

Если в системе установлено несколько устройств захвата видео, то нужное можно выбрать с помощью раскрывающегося списка на панели управления Video Recorder. При старте Video Recorder автоматически подключает устройство, выбранное в предыдущем сеансе.

Для выхода из Video Recorder можно либо закрыть его окно как обычно, либо нажать кнопку [image] на панели управления.

Смотри также

Установка режима мониторинга


установка режима мониторинга

VideoRecorder

Установка режима мониторинга.

Некоторые устройства захвата видео поддерживают режим непосредственного отображения видео на дисплее компьютера (Overlay mode). В этом случае вычислительные ресурсы системы используются минимально, а частота кадров отображения видео на дисплее компьютера равна частоте кадров видео на входе. Для всех остальных устройств, не поддерживающих данный режим, мониторинг осуществляется за счёт вычислительных ресурсов системы, и частота кадров отображения видео обычно несколько меньше.

Если установлено устройство с возможностью непосредственного отображения видео (Overlay mode), то данная кнопка на панели управления разрешена. Если кнопка нажата, то режим непосредственного отображения видео включен (кнопка имеет независимую фиксацию).

Если при нажатии данной кнопки курсор мыши расположен в районе стрелки вниз, то будет выведен диалог установки параметров режима непосредственного отображения, если драйвер устройства ввода видео поддерживает такой диалог.

Смотри также

Параметры мониторинга


Синхронизация MCI устройства

VideoRecorder

Синхронизация MCI устройства.

В системе может быть установлено устройство MCI (Multimedia Control Interface), управляющее источником видео, то такое устройство можно синхронизировать с операцией захвата. В частности, это может быть устройство управления видеомагнитофоном, и можно установить начало и конец фрагмента для записи.

Если в системе установлено MCI устройство типа VCR или Videodisk, то данная кнопка разрешена. Если кнопка нажата, то захват видео будет синхронизирован с устройством MCI (кнопка имеет независимую фиксацию).

Смотри также

Захват


Установка параметров аудио

VideoRecorder

Установка параметров аудио.

Если в системе имеется устройство ввода аудио (звуковая карта), то эта кнопка разрешена. Если кнопка нажата, то вместе с видео будет записываться также и звук (кнопка имеет независимую фиксацию).

Если при нажатии кнопки [image] курсор мыши расположен в районе стрелки вниз, то будет выведен стандартный диалог выбора формата записи аудио.

В диалоговом окне "Выбор звука" выберите Название из ниспадающего списка, оно будет определять схему настроек. Выберите Формат и Атрибуты (частоту, количество бит, моно или стерео, скорость) записи аудио из ниспадающего списка, которые позволяет установить выбранная схема настроек. Для ввода нажмите ОК, для отказа нажмите "Отмена".

Смотри также

Выбор параметров источника видео


Выбор параметров источника видео

VideoRecorder

Выбор параметров источника видео.

Драйверы устройств ввода видео обычно поддерживают несколько встроенных диалогов. Диалог "Видео источник" – один из них, получаемый при использовании драйвера DTOL Video Capture Device Driver для устройства, соответствующего стандарту DTOL ( Data Translation's Open Layers ).

Обычно в этом диалоге можно установить такие параметры как яркость, контраст, цветовая насыщенность, иными словами уровни черного и белого, усиление, смещение и опора.

Если диалог поддерживается драйвером устройства ввода видео, то кнопка [image] разрешена. При нажатии на кнопку указанный диалог будет выведен.

Смотри также

Выбор формата видео


Выбор формата видео

VideoRecorder

Выбор формата видео.

Драйверы устройств ввода видео обычно поддерживают несколько встроенных диалогов. Диалог "Видео формат" - один из них, получаемый при использовании драйвера DTOL Video Capture Device Driver для устройства, соответствующего стандарту DTOL ( Data Translation's Open Layers ).

Обычно в этом диалоге можно установить такие параметры как Высота и Ширина кадра. Высота измеряется в количестве линий, а ширина в пикселах. Параметры Лево и Верх означают отступы слева и сверху в активной области кадра (активная область кадра задается в дополнительных параметрах).

Параметр Аспект определяет изменение соотношения вертикального и горизонтального размера и регулируется вставкой или удалением строк. Если Аспект равен 2, то каждая строка повторяется; если Аспект равен 0.5 , то каждая вторая строка пропускается.

Параметр Поворот определяет поворот кадра на определенный угол и измеряется в градусах. При выборе Зеркало получим зеркальное отражение кадра. Последовательность операций следующая: Аспект, Поворот, Зеркало.

Если диалог поддерживается драйвером устройства ввода видео, то кнопка [image] разрешена. При нажатии на кнопку указанный диалог будет выведен.

Смотри также

Выбор параметров источника видео


Установка параметров сжатия видео

VideoRecorder

Установка параметров сжатия видео.

В системе может быть установлен программный или аппаратно-программный компрессор видео. Такой компрессор может быть также встроен в оборудование устройства захвата видео. При пользовании компрессором необходимо помнить, что сжатие видео обычно осуществляется с потерей качества, зависящей от степени сжатия. Кроме того программное сжатие может занять существенное время, так что скорость ввода может существенно упасть.

При нажатии на данную кнопку будет выведен стандартный диалог выбора компрессора и установки параметров сжатия.

Программу сжатия выберите из ниспадающего списка.

Качество сжатия установите с помощью движка, по умолчанию для каждой программы предлагается определенная величина.

Установите через сколько кадров должен идти опорный кадр, если число не установлено, то опорным будет принят первый кадр. Это требуется для того чтобы ошибка при сжатии не накапливалась. Например, опорный кадр каждые 15 кадров. В начале опорный - 1-й кадр, он и записывается без изменений. Далее сжимается и записывается разница между кадрами, 15-й кадр записывается без изменений и т.д. Таким образом ошибка не накапливается.

Так же для каждой программы сжатия можно посмотреть её настройки с помощью кнопки.

Смотри также

Захват


Работа с палитрой

VideoRecorder

Работа с палитрой.

Если драйвер устройства ввода видео поддерживает работу с палитрой, то данная кнопка разрешена.

Нажатие на неё выводит ниспадающее меню, с помощью которого можно сохранить текущую палитру, загрузить предварительно сохранённую палитру, а также захватить палитру, - т.е. оптимизировать палитру под конкретный видеосигнал.

В первых двух случаях выводятся стандартные диалоги открытия и сохранения файлов.

В последнем случае выводится диалог захвата палитры, в котором можно сделать это автоматически по всем кадрам или по конкретно указанным кадрам.

После нажатия кнопки "Старт" вместо двух кнопок появляется одна "Закончить". Внизу окна будет фиксироваться количество захваченных кадров.

Если захват палитры производить по выбранным кадрам, то в место кнопки "Старт" появится кнопка "Кадр!". Количество нажатий на кнопку равно количеству выбранных кадров.

Смотри также

Выбор параметров источника видео


Установка скорости захвата видео

VideoRecorder

Установка скорости захвата видео.

Захват видео можно осуществлять автоматически с определённой скоростью или по кадрам.

Для автоматического захвата данная кнопка с независимой фиксацией должна быть нажата. При этом поле ввода скорости захвата разрешено, и можно установить желаемую скорость (в кадрах в секунду). Заметим, что поддерживаются скорости ниже одного кадра в секунду, например 0.1 к/сек означает один кадр в 10 секунд.

Для ввода видео по кадрам данная кнопка должна быть отжата (поле ввода скорости захвата при этом запрещено). В этом режиме захват очередного кадра осуществляется при нажатии кнопки [image] Снимок, и захват продолжается до тех пор пока не будет нажата кнопка [image] Стоп.

Смотри также

Автоматический захват видео

Захват видео по кадрам


Установка таймера захвата видео

VideoRecorder

Установка таймера захвата видео.

При автоматическом режиме захвата видео можно установить таймер максимального времени захвата.

Если данная кнопка с независимой фиксацией нажата, то поле ввода максимального времени захвата видео разрешено, и можно установить желаемое значение. По истечении указанного времени операция захвата будет завершена (захват можно закончить также досрочно обычным образом).

Смотри также

Автоматический захват видео


Выбор режима захвата

VideoRecorder

Выбор режима захвата.

Можно захватывать не только видео (автоматически или по кадрам), но и одиночные кадры.

Данные кнопки с зависимой фиксацией переключают режим захвата видео и режим захвата одиночных кадров соответственно.

Если нажата кнопка [image] , то установлен режим захвата видео, а если нажата кнопка [image] , то - режим захвата одиночного кадра.

Режим захвата видео по кадрам обычно используется для сокращения длины видео клипа, путем выбора самых важных кадров.

Смотри также

Захват

Автоматический захват видео

Захват видео по кадрам

Захват одиночного кадра


Захват

VideoRecorder

Захват.

Video Recorder записывает видео непосредственно в файл, расположенный на жёстком диске компьютера. Поскольку этот файл может быть очень большим (до 2 Гб), предприняты меры для исключения лишних операций копирования.

Поддерживается заранее подготовленный к захвату файл (см. Параметры файлов видео), чтобы уменьшить время, необходимое для инициализации операции захвата. Этот файл имеет автоматически сгенерированное специальное имя. После успешного захвата Video Recorder предлагает просто переименовать этот файл. Если переименование происходит в пределах одного и того же логического диска – длительной операции копирования удаётся избежать.

Максимальный размер файла видео, который можно записать, определяется реализацией Video For Windows и составляет 2 Гб. Однако, к сожалению, ни Video For Windows, ни Video Recorder не контролируют размер этого файла при записи (мы надеемся, что в следующей версии Video Recorder этот недостаток будет устранён), и, если файл превысит максимальный размер, прочитать его будет невозможно.

Размер файла определяется размером кадра, частотой кадров, временем записи и установленным компрессором видео. Например, для видео 512 х 512 х 8 бит без сжатия (= 256 Кб) и без звука, максимальное время записи при скорости 25 к/сек составляет не более 5 минут, при 12.5 к/сек – 10 минут и т.д., при 1 к/сек – около 2 часов.

Можно осуществлять захват одиночного кадра или видео (автоматически или по кадрам), предварительно выбрав режим захвата.

Смотри также

Автоматический захват видео

Захват видео по кадрам

Захват одиночного кадра

Выбор режима захвата


Автоматический захват видео

VideoRecorder

Автоматический захват видео.

Для захвата видео кнопка [image] должна быть нажата. Также должна быть нажата кнопка [image] и установлена желаемая скорость ввода в соответствующем поле. Кроме того может быть нажата кнопка [image] и установлено максимальное время захвата видео.

При нажатии кнопки [image] захват начнётся немедленно (максимальная задержка не превышает 1 секунды). Если захват синхронизирован с MCI – устройством, то последнее соответствующим образом позиционируется, и захват автоматически начинается с указанного места.

Внизу панели управления указывается :

"Длительность: <время проигрывания клипа>с

Кадров:<количество кадров в клипе>(пропущено<количество пропущенных кадров>)

(<скорость проигрывания клипа>кадров/с)".

После того как захват завершен появляется диалоговое окно "Переименование/перемещение захваченного клипа", аналогичное стандартному диалогу сохранения файлов.

Захват заканчивается при нажатии клавиши ESC на клавиатуре или по истечении максимального времени захвата, предварительно установленного таймером захвата видео.

Смотри также

Синхронизация МСI устройства

Установка таймера захвата видео

Установка скорости захвата видео

Захват видео по кадрам

Захват одиночного кадра

Выбор режима захвата

Захват


Захват видео

VideoRecorder

Захват видео по кадрам.

Для захвата видео по кадрам кнопка [image] должна быть нажата. Кнопка [image] должна быть отжата (автоматический захват отменён). Кнопка [image] становится недоступной.

При нажатии кнопки [image], она заменяется на две кнопки – [image] и [image] , при этом кнопка [image] становится недоступной.

Каждый раз когда нажимается кнопка [image], происходит захват очередного кадра. Внизу панели управления появляется надпись "Записано кадров: <количество захваченных кадров>".

Захват заканчивается при нажатии на кнопку [image]. После этого появляется диалоговое окно "Переименование/перемещение захваченного клипа", аналогичное стандартному диалогу сохранения файлов. Захваченные кадры будут сохранены также в виде клипа (файл видео).

Смотри также

Автоматический захват видео

Захват одиночного кадра

Выбор режима захвата

Захват


Захват одиночного кадра

VideoRecorder

Захват одиночного кадра.

Для захвата одиночных кадров кнопка [image] должна быть нажата. При этом кнопки [image] и [image] становятся недоступны.

При нажатии кнопки [image] текущий кадр захватывается. После этого появляется диалоговое окно "Переименование/перемещение захваченного клипа", аналогичное стандартному диалогу сохранения файлов.

Смотри также

Автоматический захват видео

Захват видео по кадрам

Выбор режима захвата

Захват


Установка параметров Video Recorder'a

VideoRecorder

Установка параметров Video Recorderа.

Video Recorder позволяет установить ряд специальных параметров для настройки и оптимизации.

Параметры файлов видео, захвата видео и мониторинга.

Смотри также

Параметры файлов видео

Параметры захвата видео

Параметры мониторинга


Параметры файлов видео

VideoRecorder

Параметры файлов видео.

После нажатия кнопки [image] появится диалоговое окно "Параметры Video Recorder" выберите закладку "Файл".

Можно установить рабочий каталог, в который будут помещаться файлы захваченного видео. Указанный каталог должен существовать. По умолчанию (при первом старте) рабочим каталогом считается каталог, в котором находится сам Video Recorder. Важно правильно выбрать каталог, чтобы избежать лишних операций копирования.

Префикс представляет из себя первые три буквы в имени файла, а текущий номер - последние четыре цифры в имени файла.

В заголовке окна видео клипа перед именем файла будет стоять значок [image] .

Если дисковая подсистема компьютера слишком медленная, можно попробовать предварительный захват пространства на диске – он будет осуществляться автоматически. Иногда таким способом можно увеличить скорость ввода. Если предварительный захват пространства не требуется – установите 0 в соответствующем поле ввода.

Смотри также

Установка специальных параметров


Параметры захвата видео

VideoRecorder

Параметры захвата видео.

После нажатия кнопки [image] появится диалоговое окно "Параметры Video Recorder" выберите закладку "Захват".

Можно установить некоторые параметры захвата видео, которые изменяются достаточно редко.

Файл видео содержит участок фиксированной длины в котором записывается индексы кадров, поэтому Video For Windows необходимо предварительно знать, сколько максимально может быть кадров. Чем больше заданное значение – тем больше длина файла при прочих равных условиях. Значение по умолчанию – 34952.

Если требуемая скорость ввода не может быть обеспечена, некоторые кадры будут пропущены. Будет также сгенерирована ошибка, если больше чем указанный процент кадров было пропущено.

При захвате видео, если аудио тоже захватывается, процедура может быть синхронизирована по аудио, однако, это может увеличить процент пропущенных кадров.

Обычно, захват прекращается по нажатию клавиши ESC на клавиатуре. Дополнительно для этого могут использоваться левая и правая кнопки мыши.

Смотри также

Автоматический захват видео

Захват видео по кадрам

Захват одиночного кадра

Выбор режима захвата

Захват


Параметры мониторинга

VideoRecorder

Параметры мониторинга.

После нажатия кнопки [image] появится диалоговое окно "Параметры Video Recorder" выберите закладку "Монитор".

Цвет фона окна Video Recorder можно установить по желанию (в % серого).

Можно также включить режим, при котором размер окна Video Recorder будет автоматически отслеживать размер видео (в данной версии не реализовано).

Смотри также

Установка режима мониторинга


Тана

VideoRecorder

TANA Logo Компания"ТАНА"
medical imaging systems
Адрес: | г. Москва, Староваганьковский пер., д.15, офис 14
Тел.: | (095) 202-1212
Факс: | (095) 202-0845
E-mail: | tana-com@space.ru
WWW: | http://www.tana.ru

Лицензия на производство, реализацию и техническое обслуживание

медицинской техники №42/2000-1151-1150 от 24.05.2000г.


print

Справка по Video Recorder

© OOO"ТАНА" 2000г

Содержание

Назначение программы | 4
Особенности работы с видео | 4
Запуск программы и выбор устройства | 5
Установка режима мониторинга | 6
Синхронизация MCI устройства | 6
Установка параметров аудио | 6
Выбор параметров источника видео | 7
Выбор формата видео | 8
Установка параметров сжатия | 8
Работа с палитрой | 9
Установка скорости захвата видео | 10
Установка таймера захвата видео | 10
Выбор режима захвата | 10
Захват | 11
Автоматический захват видео Захват видео по кадрам Захват одиночного кадра | 11 11 12
Установка параметров Video Recorder'a | 13
Параметры файлов видео Параметры захвата видео Параметры мониторинга | 13 13 14
Специальные элементы управления | 15
Специальные элементы управления | 16
ТАНА | 17

Назначение программы.

Video Recorder предназначен для записи видео, используя установленные в системе драйверы Video Capture Devices, отвечающие спецификации Video For Windows. С помощью этой программы можно записывать как непрерывное видео, так и одиночные кадры. Video Recorder записывает видео непосредственно в файл, расположенный на жёстком диске компьютера.

Video Recorder является самостоятельной программой, однако может работать под управлением других программных продуктов выпускаемых компанией "TAHA".

Особенности работы с видео.

Video Recorder записывает видео непосредственно в файл, расположенный на жёстком диске компьютера. Поскольку этот файл может быть очень большим (до 2 Гб), предприняты меры для исключения лишних операций копирования.

Video Recorder постоянно держит заранее подготовленный к захвату файл, чтобы уменьшить время, необходимое для инициализации операции захвата. Этот файл имеет автоматически сгенерированное специальное имя. После успешного захвата Video Recorder предлагает просто переименовать этот файл. Если переименование происходит в пределах одного и того же логического диска – длительной операции копирования удаётся избежать.

Максимальный размер файла видео, который можно записать, определяется реализацией Video For Windows и составляет 2 Гб. Однако, к сожалению, ни Video For Windows, ни Video Recorder не контролируют размер этого файла при записи (мы надеемся, что в следующей версии Video Recorder этот недостаток будет устранён), и, если файл превысит максимальный размер, прочитать его будет невозможно.

Размер файла определяется размером кадра, частотой кадров, временем записи и установленным компрессором видео. Например, для видео 512 х 512 х 8 бит без сжатия (= 256 Кб) и без звука, максимальное время записи при скорости 25 к/сек составляет не более 5 минут, при 12.5 к/сек – 10 минут и т.д., при 1 к/сек – около 2 часов.

Запуск программы и выбор устройства.

Video Recorder можно запустить как самостоятельное приложение (т.е. также как и любое другое приложение Windows) или под управлением другого программного обеспечения TANA (смотрите соответствующую документацию по этому программному обеспечению). В последнем случае заголовок окна Video Recorder имеет форму:

Video Recorder for <Имя_управляющей_программы>.

Окно Video Recorder представляет собой монитор текущего видео на входе (если, конечно, устройство ввода видео правильно установлено и выбрано).

Окно также имеет панель управления, которую можно расположить как больше нравится: прикрепить слева или справа, а также открепить и расположить отдельно. Окно Video Recorder (также как и панель управления) запоминает своё расположение на экране от сеанса к сеансу.

Если в системе установлено несколько устройств захвата видео, то нужное можно выбрать с помощью раскрывающегося списка на панели управления Video Recorder. При старте Video Recorder автоматически подключает устройство, выбранное в предыдущем сеансе.

Для выхода из Video Recorder можно либо закрыть его окно как обычно, либо нажать кнопку [image] на панели управления.

Установка режима мониторинга.

Некоторые устройства захвата видео поддерживают режим непосредственного отображения видео на дисплее компьютера (Overlay mode). В этом случае вычислительные ресурсы системы используются минимально, а частота кадров отображения видео на дисплее компьютера равна частоте кадров видео на входе. Для всех остальных устройств, не поддерживающих данный режим, мониторинг осуществляется за счёт вычислительных ресурсов системы, и частота кадров отображения видео обычно несколько меньше.

Если установлено устройство с возможностью непосредственного отображения видео (Overlay mode), то данная кнопка на панели управления разрешена. Если кнопка нажата, то режим непосредственного отображения видео включен (кнопка имеет независимую фиксацию).

Если при нажатии данной кнопки курсор мыши расположен в районе стрелки вниз, то будет выведен диалог установки параметров режима непосредственного отображения, если драйвер устройства ввода видео поддерживает такой диалог.

Синхронизация MCI устройства.

В системе может быть установлено устройство MCI (Multimedia Control Interface), управляющее источником видео, то такое устройство можно синхронизировать с операцией захвата. В частности, это может быть устройство управления видеомагнитофоном, и можно установить начало и конец фрагмента для записи.

Если в системе установлено MCI устройство типа VCR или Videodisk, то данная кнопка разрешена. Если кнопка нажата, то захват видео будет синхронизирован с устройством MCI (кнопка имеет независимую фиксацию).

Установка параметров аудио.

Если в системе имеется устройство ввода аудио (звуковая карта), то эта кнопка разрешена. Если кнопка нажата, то вместе с видео будет записываться также и звук (кнопка имеет независимую фиксацию).

Если при нажатии кнопки [image] курсор мыши расположен в районе стрелки вниз, то будет выведен стандартный диалог выбора формата записи аудио.

В диалоговом окне "Выбор звука" выберите Название из ниспадающего списка, оно будет определять схему настроек. Выберите Формат и Атрибуты (частоту, количество бит, моно или стерео, скорость) записи аудио из ниспадающего списка, которые позволяет установить выбранная схема настроек. Для ввода нажмите ОК, для отказа нажмите "Отмена".

Выбор параметров источника видео.

Драйверы устройств ввода видео обычно поддерживают несколько встроенных диалогов. Диалог "Видео источник" – один из них, получаемый при использовании драйвера DTOL Video Capture Device Driver для устройства, соответствующего стандарту DTOL ( Data Translation's Open Layers ).

Обычно в этом диалоге можно установить такие параметры как яркость, контраст, цветовая насыщенность, иными словами уровни черного и белого, усиление, смещение и опора.

Если диалог поддерживается драйвером устройства ввода видео, то кнопка [image] разрешена. При нажатии на кнопку указанный диалог будет выведен.

Выбор формата видео.

Драйверы устройств ввода видео обычно поддерживают несколько встроенных диалогов. Диалог "Видео формат" - один из них, получаемый при использовании драйвера DTOL Video Capture Device Driver для устройства, соответствующего стандарту DTOL ( Data Translation's Open Layers ).

Обычно в этом диалоге можно установить такие параметры как Высота и Ширина кадра. Высота измеряется в количестве линий, а ширина в пикселах. Параметры Лево и Верх означают отступы слева и сверху в активной области кадра (активная область кадра задается в дополнительных параметрах).

Параметр Аспект определяет изменение соотношения вертикального и горизонтального размера и регулируется вставкой или удалением строк. Если Аспект равен 2, то каждая строка повторяется; если Аспект равен 0.5 , то каждая вторая строка пропускается.

Параметр Поворот определяет поворот кадра на определенный угол и измеряется в градусах. При выборе Зеркало получим зеркальное отражение кадра. Последовательность операций следующая: Аспект, Поворот, Зеркало.

Если диалог поддерживается драйвером устройства ввода видео, то кнопка [image] разрешена. При нажатии на кнопку указанный диалог будет выведен.

Установка параметров сжатия видео.

В системе может быть установлен программный или аппаратно-программный компрессор видео. Такой компрессор может быть также встроен в оборудование устройства захвата видео. При пользовании компрессором необходимо помнить, что сжатие видео обычно осуществляется с потерей качества, зависящей от степени сжатия. Кроме того программное сжатие может занять существенное время, так что скорость ввода может существенно упасть.

При нажатии на данную кнопку будет выведен стандартный диалог выбора компрессора и установки параметров сжатия.

Программу сжатия выберите из ниспадающего списка.

Качество сжатия установите с помощью движка, по умолчанию для каждой программы предлагается определенная величина.

Установите через сколько кадров должен идти опорный кадр, если число не установлено, то опорным будет принят первый кадр. Это требуется для того чтобы ошибка при сжатии не накапливалась. Например, опорный кадр каждые 15 кадров. В начале опорный - 1-й кадр, он и записывается без изменений. Далее сжимается и записывается разница между кадрами, 15-й кадр записывается без изменений и т.д. Таким образом ошибка не накапливается.

Так же для каждой программы сжатия можно посмотреть её настройки с помощью кнопки.

Работа с палитрой.

Если драйвер устройства ввода видео поддерживает работу с палитрой, то данная кнопка разрешена.

Нажатие на неё выводит ниспадающее меню, с помощью которого можно сохранить текущую палитру, загрузить предварительно сохранённую палитру, а также захватить палитру, - т.е. оптимизировать палитру под конкретный видеосигнал.

В первых двух случаях выводятся стандартные диалоги открытия и сохранения файлов.

В последнем случае выводится диалог захвата палитры, в котором можно сделать это автоматически по всем кадрам или по конкретно указанным кадрам.

После нажатия кнопки "Старт" вместо двух кнопок появляется одна "Закончить". Внизу окна будет фиксироваться количество захваченных кадров.

Если захват палитры производить по выбранным кадрам, то в место кнопки "Старт" появится кнопка "Кадр!". Количество нажатий на кнопку равно количеству выбранных кадров.

Установка скорости захвата видео.

Захват видео можно осуществлять автоматически с определённой скоростью или по кадрам.

Для автоматического захвата данная кнопка с независимой фиксацией должна быть нажата. При этом поле ввода скорости захвата разрешено, и можно установить желаемую скорость (в кадрах в секунду). Заметим, что поддерживаются скорости ниже одного кадра в секунду, например 0.1 к/сек означает один кадр в 10 секунд.

Для ввода видео по кадрам данная кнопка должна быть отжата (поле ввода скорости захвата при этом запрещено). В этом режиме захват очередного кадра осуществляется при нажатии кнопки [image] Снимок, и захват продолжается до тех пор пока не будет нажата кнопка [image] Стоп.

Установка таймера захвата видео.

При автоматическом режиме захвата видео можно установить таймер максимального времени захвата.

Если данная кнопка с независимой фиксацией нажата, то поле ввода максимального времени захвата видео разрешено, и можно установить желаемое значение. По истечении указанного времени операция захвата будет завершена (захват можно закончить также досрочно обычным образом).

Выбор режима захвата.

Можно захватывать не только видео (автоматически или по кадрам), но и одиночные кадры.

Данные кнопки с зависимой фиксацией переключают режим захвата видео и режим захвата одиночных кадров соответственно.

Если нажата кнопка [image] , то установлен режим захвата видео, а если нажата кнопка [image] , то - режим захвата одиночного кадра.

Режим захвата видео по кадрам обычно используется для сокращения длины видео клипа, путем выбора самых важных кадров.

Захват.

Video Recorder записывает видео непосредственно в файл, расположенный на жёстком диске компьютера. Поскольку этот файл может быть очень большим (до 2 Гб), предприняты меры для исключения лишних операций копирования.

Поддерживается заранее подготовленный к захвату файл (см. Параметры файлов видео), чтобы уменьшить время, необходимое для инициализации операции захвата. Этот файл имеет автоматически сгенерированное специальное имя. После успешного захвата Video Recorder предлагает просто переименовать этот файл. Если переименование происходит в пределах одного и того же логического диска – длительной операции копирования удаётся избежать.

Максимальный размер файла видео, который можно записать, определяется реализацией Video For Windows и составляет 2 Гб. Однако, к сожалению, ни Video For Windows, ни Video Recorder не контролируют размер этого файла при записи (мы надеемся, что в следующей версии Video Recorder этот недостаток будет устранён), и, если файл превысит максимальный размер, прочитать его будет невозможно.

Размер файла определяется размером кадра, частотой кадров, временем записи и установленным компрессором видео. Например, для видео 512 х 512 х 8 бит без сжатия (= 256 Кб) и без звука, максимальное время записи при скорости 25 к/сек составляет не более 5 минут, при 12.5 к/сек – 10 минут и т.д., при 1 к/сек – около 2 часов.

Можно осуществлять захват одиночного кадра или видео (автоматически или по кадрам), предварительно выбрав режим захвата.

Автоматический захват видео.

Для захвата видео кнопка [image] должна быть нажата. Также должна быть нажата кнопка [image] и установлена желаемая скорость ввода в соответствующем поле. Кроме того может быть нажата кнопка [image] и установлено максимальное время захвата видео.

При нажатии кнопки [image] захват начнётся немедленно (максимальная задержка не превышает 1 секунды). Если захват синхронизирован с MCI – устройством, то последнее соответствующим образом позиционируется, и захват автоматически начинается с указанного места.

Внизу панели управления указывается :

"Длительность: <время проигрывания клипа>с

Кадров:<количество кадров в клипе>(пропущено<количество пропущенных кадров>)

(<скорость проигрывания клипа>кадров/с)".

После того как захват завершен появляется диалоговое окно "Переименование/перемещение захваченного клипа", аналогичное стандартному диалогу сохранения файлов.

Захват заканчивается при нажатии клавиши ESC на клавиатуре или по истечении максимального времени захвата, предварительно установленного таймером захвата видео.

Захват видео по кадрам.

Для захвата видео по кадрам кнопка [image] должна быть нажата. Кнопка [image] должна быть отжата (автоматический захват отменён). Кнопка [image] становится недоступной.

При нажатии кнопки [image], она заменяется на две кнопки – [image] и [image] , при этом кнопка [image] становится недоступной.

Каждый раз когда нажимается кнопка [image], происходит захват очередного кадра. Внизу панели управления появляется надпись "Записано кадров: <количество захваченных кадров>".

Захват заканчивается при нажатии на кнопку [image]. После этого появляется диалоговое окно "Переименование/перемещение захваченного клипа", аналогичное стандартному диалогу сохранения файлов. Захваченные кадры будут сохранены также в виде клипа (файл видео).

Захват одиночного кадра.

Для захвата одиночных кадров кнопка [image] должна быть нажата. При этом кнопки [image] и [image] становятся недоступны.

При нажатии кнопки [image] текущий кадр захватывается. После этого появляется диалоговое окно "Переименование/перемещение захваченного клипа", аналогичное стандартному диалогу сохранения файлов.

Установка параметров Video Recorderа.

Video Recorder позволяет установить ряд специальных параметров для настройки и оптимизации.

Параметры файлов видео, захвата видео и мониторинга.

Параметры файлов видео.

После нажатия кнопки [image] появится диалоговое окно "Параметры Video Recorder" выберите закладку "Файл".

Можно установить рабочий каталог, в который будут помещаться файлы захваченного видео. Указанный каталог должен существовать. По умолчанию (при первом старте) рабочим каталогом считается каталог, в котором находится сам Video Recorder. Важно правильно выбрать каталог, чтобы избежать лишних операций копирования.

Префикс представляет из себя первые три буквы в имени файла, а текущий номер - последние четыре цифры в имени файла.

В заголовке окна видео клипа перед именем файла будет стоять значок [image] .

Если дисковая подсистема компьютера слишком медленная, можно попробовать предварительный захват пространства на диске – он будет осуществляться автоматически. Иногда таким способом можно увеличить скорость ввода. Если предварительный захват пространства не требуется – установите 0 в соответствующем поле ввода.

Параметры захвата видео.

После нажатия кнопки [image] появится диалоговое окно "Параметры Video Recorder" выберите закладку "Захват".

Можно установить некоторые параметры захвата видео, которые изменяются достаточно редко.

Файл видео содержит участок фиксированной длины в котором записывается индексы кадров, поэтому Video For Windows необходимо предварительно знать, сколько максимально может быть кадров. Чем больше заданное значение – тем больше длина файла при прочих равных условиях. Значение по умолчанию – 34952.

Если требуемая скорость ввода не может быть обеспечена, некоторые кадры будут пропущены. Будет также сгенерирована ошибка, если больше чем указанный процент кадров было пропущено.

При захвате видео, если аудио тоже захватывается, процедура может быть синхронизирована по аудио, однако, это может увеличить процент пропущенных кадров.

Обычно, захват прекращается по нажатию клавиши ESC на клавиатуре. Дополнительно для этого могут использоваться левая и правая кнопки мыши.

Параметры мониторинга.

После нажатия кнопки [image] появится диалоговое окно "Параметры Video Recorder" выберите закладку "Монитор".

Цвет фона окна Video Recorder можно установить по желанию (в % серого).

Можно также включить режим, при котором размер окна Video Recorder будет автоматически отслеживать размер видео (в данной версии не реализовано).

Использование схем.

Диалоги "Видео Формат" и "Видео Источник" имеют панель инструментов для работы со схемами.

Схемой называется совокупность параметров устройства, однозначно определяющая его работу. Схемы устанавливаются раздельно для каждого из видеовходов устройства, однако существует режим, при котором для всех видеовходов устанавливается одна и та же схема (Based Source Mode).

Программа автоматически сохраняет в конце сеанса работы и восстанавливает в начале следующего сеанса текущие схемы для всех видеовходов устройства. Дополнительно Вы можете запоминать текущую схему под уникальным именем и впоследствии восстанавливать её, что должно избавить Вас от установки необходимых параметров каждый раз вручную.

Доступ к схемам предоставляет панель инструментов.

Выбрать нужный видеовход устройства.

Установить схему для выбранного видеовхода.

Сохранить текущие параметры устройства в виде схемы. Появится диалог, в котором у Вас будет запрошено имя схемы.

Удалить ненужную схему. Появится диалог, в котором Вы можете это делать.

Получить доступ к специальным параметрам, если это разрешено конфигурацией. Появится соответствующий диалог.

Установить одну и ту же схему для всех входов (Based Source Mode). Схема для текущего видеовхода будет установлена для остальных.

Ниже приведены диалоги для сохранения и удаления схем.

Специальные элементы управления.

Для ввода необходимых параметров используются управляющие элементы, которые могут показаться Вам незнакомыми.

Поле ввода со стрелками позволяет вводить числовую величину, не набирая её на клавиатуре. От стандартного отличается наличием перекладины между стрелками, позволяющей “протягивать” значение с помощью мыши.

Нажатие с помощью мыши на стрелку вверх увеличивает числовую величину, а на стрелку вниз - уменьшает. Если кнопка мыши удерживается нажатой - изменение продолжается.

Нажатие с помощью мыши на перекладину - при этом курсор такой, как показан - и перемещение мыши с удержанием нажатой кнопки вверх - увеличивает, а вниз - уменьшает величину.

Клавиши со стрелками вверх и вниз, а также PgUp и PgDn на клавиатуре также позволяют менять числовую величину, но при этом фокус должен находиться на поле ввода. Таким способом удобно подбирать какой-либо параметр, например, уровни чёрного и белого.

TANA Logo Компания"ТАНА"
medical imaging systems
Адрес: | г. Москва, Староваганьковский пер., д.15, офис 14
Тел.: | (095) 202-1212
Факс: | (095) 202-0845
E-mail: | tana-com@space.ru
WWW: | http://www.tana.ru

Лицензия на производство, реализацию и техническое обслуживание

медицинской техники №42/2000-1151-1150 от 24.05.2000г.


О программе

Назначение программы.

Video Recorder предназначен для записи видео, используя установленные в системе драйверы Video Capture Devices, отвечающие спецификации Video For Windows. С помощью этой программы можно записывать как непрерывное видео, так и одиночные кадры. Video Recorder записывает видео непосредственно в файл, расположенный на жёстком диске компьютера.

Video Recorder является самостоятельной программой, однако может работать под управлением других программных продуктов выпускаемых компанией "TAHA".


Автоматический захват видео.

Для захвата видео кнопка [image] должна быть нажата. Также должна быть нажата кнопка [image] и установлена желаемая скорость ввода в соответствующем поле. Кроме того может быть нажата кнопка [image] и установлено максимальное время захвата видео.

При нажатии кнопки [image] захват начнётся немедленно (максимальная задержка не превышает 1 секунды). Если захват синхронизирован с MCI – устройством, то последнее соответствующим образом позиционируется, и захват автоматически начинается с указанного места.

Внизу панели управления указывается :

"Длительность: <время проигрывания клипа>с

Кадров:<количество кадров в клипе>(пропущено<количество пропущенных кадров>)

(<скорость проигрывания клипа>кадров/с)".

После того как захват завершен появляется диалоговое окно "Переименование/перемещение захваченного клипа", аналогичное стандартному диалогу сохранения файлов.

Захват заканчивается при нажатии клавиши ESC на клавиатуре или по истечении максимального времени захвата, предварительно установленного таймером захвата видео.


Выбор формата видео.

Драйверы устройств ввода видео обычно поддерживают несколько встроенных диалогов. Диалог "Видео формат" - один из них, получаемый при использовании драйвера DTOL Video Capture Device Driver для устройства, соответствующего стандарту DTOL ( Data Translation's Open Layers ).

Обычно в этом диалоге можно установить такие параметры как Высота и Ширина кадра. Высота измеряется в количестве линий, а ширина в пикселах. Параметры Лево и Верх означают отступы слева и сверху в активной области кадра (активная область кадра задается в дополнительных параметрах).

Параметр Аспект определяет изменение соотношения вертикального и горизонтального размера и регулируется вставкой или удалением строк. Если Аспект равен 2, то каждая строка повторяется; если Аспект равен 0.5 , то каждая вторая строка пропускается.

Параметр Поворот определяет поворот кадра на определенный угол и измеряется в градусах. При выборе Зеркало получим зеркальное отражение кадра. Последовательность операций следующая: Аспект, Поворот, Зеркало.

Если диалог поддерживается драйвером устройства ввода видео, то кнопка [image] разрешена. При нажатии на кнопку указанный диалог будет выведен.


Установка режима мониторинга.

Некоторые устройства захвата видео поддерживают режим непосредственного отображения видео на дисплее компьютера (Overlay mode). В этом случае вычислительные ресурсы системы используются минимально, а частота кадров отображения видео на дисплее компьютера равна частоте кадров видео на входе. Для всех остальных устройств, не поддерживающих данный режим, мониторинг осуществляется за счёт вычислительных ресурсов системы, и частота кадров отображения видео обычно несколько меньше.

Если установлено устройство с возможностью непосредственного отображения видео (Overlay mode), то данная кнопка на панели управления разрешена. Если кнопка нажата, то режим непосредственного отображения видео включен (кнопка имеет независимую фиксацию).

Если при нажатии данной кнопки курсор мыши расположен в районе стрелки вниз, то будет выведен диалог установки параметров режима непосредственного отображения, если драйвер устройства ввода видео поддерживает такой диалог.


Особенности работы с видео.

Video Recorder записывает видео непосредственно в файл, расположенный на жёстком диске компьютера. Поскольку этот файл может быть очень большим (до 2 Гб), предприняты меры для исключения лишних операций копирования.

Video Recorder постоянно держит заранее подготовленный к захвату файл, чтобы уменьшить время, необходимое для инициализации операции захвата. Этот файл имеет автоматически сгенерированное специальное имя. После успешного захвата Video Recorder предлагает просто переименовать этот файл. Если переименование происходит в пределах одного и того же логического диска – длительной операции копирования удаётся избежать.

Максимальный размер файла видео, который можно записать, определяется реализацией Video For Windows и составляет 2 Гб. Однако, к сожалению, ни Video For Windows, ни Video Recorder не контролируют размер этого файла при записи (мы надеемся, что в следующей версии Video Recorder этот недостаток будет устранён), и, если файл превысит максимальный размер, прочитать его будет невозможно.

Размер файла определяется размером кадра, частотой кадров, временем записи и установленным компрессором видео. Например, для видео 512 х 512 х 8 бит без сжатия (= 256 Кб) и без звука, максимальное время записи при скорости 25 к/сек составляет не более 5 минут, при 12.5 к/сек – 10 минут и т.д., при 1 к/сек – около 2 часов.


Работа с палитрой.

Если драйвер устройства ввода видео поддерживает работу с палитрой, то данная кнопка разрешена.

Нажатие на неё выводит ниспадающее меню, с помощью которого можно сохранить текущую палитру, загрузить предварительно сохранённую палитру, а также захватить палитру, - т.е. оптимизировать палитру под конкретный видеосигнал.

В первых двух случаях выводятся стандартные диалоги открытия и сохранения файлов.

В последнем случае выводится диалог захвата палитры, в котором можно сделать это автоматически по всем кадрам или по конкретно указанным кадрам.

После нажатия кнопки "Старт" вместо двух кнопок появляется одна "Закончить". Внизу окна будет фиксироваться количество захваченных кадров.

Если захват палитры производить по выбранным кадрам, то в место кнопки "Старт" появится кнопка "Кадр!". Количество нажатий на кнопку равно количеству выбранных кадров.


Установка параметров аудио.

Если в системе имеется устройство ввода аудио (звуковая карта), то эта кнопка разрешена. Если кнопка нажата, то вместе с видео будет записываться также и звук (кнопка имеет независимую фиксацию).

Если при нажатии кнопки [image] курсор мыши расположен в районе стрелки вниз, то будет выведен стандартный диалог выбора формата записи аудио.

В диалоговом окне "Выбор звука" выберите Название из ниспадающего списка, оно будет определять схему настроек. Выберите Формат и Атрибуты (частоту, количество бит, моно или стерео, скорость) записи аудио из ниспадающего списка, которые позволяет установить выбранная схема настроек. Для ввода нажмите ОК, для отказа нажмите "Отмена".


Выбор параметров источника видео.

Драйверы устройств ввода видео обычно поддерживают несколько встроенных диалогов. Диалог "Видео источник" – один из них, получаемый при использовании драйвера DTOL Video Capture Device Driver для устройства, соответствующего стандарту DTOL ( Data Translation's Open Layers ).

Обычно в этом диалоге можно установить такие параметры как яркость, контраст, цветовая насыщенность, иными словами уровни черного и белого, усиление, смещение и опора.

Если диалог поддерживается драйвером устройства ввода видео, то кнопка [image] разрешена. При нажатии на кнопку указанный диалог будет выведен.


Параметры мониторинга.

После нажатия кнопки [image] появится диалоговое окно "Параметры Video Recorder" выберите закладку "Монитор".

Цвет фона окна Video Recorder можно установить по желанию (в % серого).

Можно также включить режим, при котором размер окна Video Recorder будет автоматически отслеживать размер видео (в данной версии не реализовано).


Установка параметров сжатия видео.

В системе может быть установлен программный или аппаратно-программный компрессор видео. Такой компрессор может быть также встроен в оборудование устройства захвата видео. При пользовании компрессором необходимо помнить, что сжатие видео обычно осуществляется с потерей качества, зависящей от степени сжатия. Кроме того программное сжатие может занять существенное время, так что скорость ввода может существенно упасть.

При нажатии на данную кнопку будет выведен стандартный диалог выбора компрессора и установки параметров сжатия.

Программу сжатия выберите из ниспадающего списка.

Качество сжатия установите с помощью движка, по умолчанию для каждой программы предлагается определенная величина.

Установите через сколько кадров должен идти опорный кадр, если число не установлено, то опорным будет принят первый кадр. Это требуется для того чтобы ошибка при сжатии не накапливалась. Например, опорный кадр каждые 15 кадров. В начале опорный - 1-й кадр, он и записывается без изменений. Далее сжимается и записывается разница между кадрами, 15-й кадр записывается без изменений и т.д. Таким образом ошибка не накапливается.

Так же для каждой программы сжатия можно посмотреть её настройки с помощью кнопки.


Параметры файлов видео.

После нажатия кнопки [image] появится диалоговое окно "Параметры Video Recorder" выберите закладку "Файл".

Можно установить рабочий каталог, в который будут помещаться файлы захваченного видео. Указанный каталог должен существовать. По умолчанию (при первом старте) рабочим каталогом считается каталог, в котором находится сам Video Recorder. Важно правильно выбрать каталог, чтобы избежать лишних операций копирования.

Префикс представляет из себя первые три буквы в имени файла, а текущий номер - последние четыре цифры в имени файла.

В заголовке окна видео клипа перед именем файла будет стоять значок [image] .

Если дисковая подсистема компьютера слишком медленная, можно попробовать предварительный захват пространства на диске – он будет осуществляться автоматически. Иногда таким способом можно увеличить скорость ввода. Если предварительный захват пространства не требуется – установите 0 в соответствующем поле ввода.


Запуск программы и выбор устройства.

Video Recorder можно запустить как самостоятельное приложение (т.е. также как и любое другое приложение Windows) или под управлением другого программного обеспечения TANA (смотрите соответствующую документацию по этому программному обеспечению). В последнем случае заголовок окна Video Recorder имеет форму:

Video Recorder for <Имя_управляющей_программы>.

Окно Video Recorder представляет собой монитор текущего видео на входе (если, конечно, устройство ввода видео правильно установлено и выбрано).

Окно также имеет панель управления, которую можно расположить как больше нравится: прикрепить слева или справа, а также открепить и расположить отдельно. Окно Video Recorder (также как и панель управления) запоминает своё расположение на экране от сеанса к сеансу.

Если в системе установлено несколько устройств захвата видео, то нужное можно выбрать с помощью раскрывающегося списка на панели управления Video Recorder. При старте Video Recorder автоматически подключает устройство, выбранное в предыдущем сеансе.

Для выхода из Video Recorder можно либо закрыть его окно как обычно, либо нажать кнопку [image] на панели управления.


Выбор режима захвата.

Можно захватывать не только видео (автоматически или по кадрам), но и одиночные кадры.

Данные кнопки с зависимой фиксацией переключают режим захвата видео и режим захвата одиночных кадров соответственно.

Если нажата кнопка [image] , то установлен режим захвата видео, а если нажата кнопка [image] , то - режим захвата одиночного кадра.

Режим захвата видео по кадрам обычно используется для сокращения длины видео клипа, путем выбора самых важных кадров.


Схема

Использование схем.

Диалоги "Видео Формат" и "Видео Источник" имеют панель инструментов для работы со схемами.

Схемой называется совокупность параметров устройства, однозначно определяющая его работу. Схемы устанавливаются раздельно для каждого из видеовходов устройства, однако существует режим, при котором для всех видеовходов устанавливается одна и та же схема (Based Source Mode).

Программа автоматически сохраняет в конце сеанса работы и восстанавливает в начале следующего сеанса текущие схемы для всех видеовходов устройства. Дополнительно Вы можете запоминать текущую схему под уникальным именем и впоследствии восстанавливать её, что должно избавить Вас от установки необходимых параметров каждый раз вручную.

Доступ к схемам предоставляет панель инструментов.

Выбрать нужный видеовход устройства.

Установить схему для выбранного видеовхода.

Сохранить текущие параметры устройства в виде схемы. Появится диалог, в котором у Вас будет запрошено имя схемы.

Удалить ненужную схему. Появится диалог, в котором Вы можете это делать.

Получить доступ к специальным параметрам, если это разрешено конфигурацией. Появится соответствующий диалог.

Установить одну и ту же схему для всех входов (Based Source Mode). Схема для текущего видеовхода будет установлена для остальных.

Ниже приведены диалоги для сохранения и удаления схем.


Синхронизация МСI устройства

Синхронизация MCI устройства.

В системе может быть установлено устройство MCI (Multimedia Control Interface), управляющее источником видео, то такое устройство можно синхронизировать с операцией захвата. В частности, это может быть устройство управления видеомагнитофоном, и можно установить начало и конец фрагмента для записи.

Если в системе установлено MCI устройство типа VCR или Videodisk, то данная кнопка разрешена. Если кнопка нажата, то захват видео будет синхронизирован с устройством MCI (кнопка имеет независимую фиксацию).


Специальные элементы управления.

Для ввода необходимых параметров используются управляющие элементы, которые могут показаться Вам незнакомыми.

Поле ввода со стрелками позволяет вводить числовую величину, не набирая её на клавиатуре. От стандартного отличается наличием перекладины между стрелками, позволяющей “протягивать” значение с помощью мыши.

Нажатие с помощью мыши на стрелку вверх увеличивает числовую величину, а на стрелку вниз - уменьшает. Если кнопка мыши удерживается нажатой - изменение продолжается.

Нажатие с помощью мыши на перекладину - при этом курсор такой, как показан - и перемещение мыши с удержанием нажатой кнопки вверх - увеличивает, а вниз - уменьшает величину.

Клавиши со стрелками вверх и вниз, а также PgUp и PgDn на клавиатуре также позволяют менять числовую величину, но при этом фокус должен находиться на поле ввода. Таким способом удобно подбирать какой-либо параметр, например, уровни чёрного и белого.


Установка параметров Video Recorder'a

Установка параметров Video Recorderа.

Video Recorder позволяет установить ряд специальных параметров для настройки и оптимизации.

Параметры файлов видео, захвата видео и мониторинга.


Установка скорости захвата видео.

Захват видео можно осуществлять автоматически с определённой скоростью или по кадрам.

Для автоматического захвата данная кнопка с независимой фиксацией должна быть нажата. При этом поле ввода скорости захвата разрешено, и можно установить желаемую скорость (в кадрах в секунду). Заметим, что поддерживаются скорости ниже одного кадра в секунду, например 0.1 к/сек означает один кадр в 10 секунд.

Для ввода видео по кадрам данная кнопка должна быть отжата (поле ввода скорости захвата при этом запрещено). В этом режиме захват очередного кадра осуществляется при нажатии кнопки [image] Снимок, и захват продолжается до тех пор пока не будет нажата кнопка [image] Стоп.


ТАНА

TANA Logo Компания"ТАНА"
medical imaging systems
Адрес: | г. Москва, Староваганьковский пер., д.15, офис 14
Тел.: | (095) 202-1212
Факс: | (095) 202-0845
E-mail: | tana-com@space.ru
WWW: | http://www.tana.ru

Лицензия на производство, реализацию и техническое обслуживание

медицинской техники №42/2000-1151-1150 от 24.05.2000г.


Установка таймера захвата видео.

При автоматическом режиме захвата видео можно установить таймер максимального времени захвата.

Если данная кнопка с независимой фиксацией нажата, то поле ввода максимального времени захвата видео разрешено, и можно установить желаемое значение. По истечении указанного времени операция захвата будет завершена (захват можно закончить также досрочно обычным образом).


Захват.

Video Recorder записывает видео непосредственно в файл, расположенный на жёстком диске компьютера. Поскольку этот файл может быть очень большим (до 2 Гб), предприняты меры для исключения лишних операций копирования.

Поддерживается заранее подготовленный к захвату файл (см. Параметры файлов видео), чтобы уменьшить время, необходимое для инициализации операции захвата. Этот файл имеет автоматически сгенерированное специальное имя. После успешного захвата Video Recorder предлагает просто переименовать этот файл. Если переименование происходит в пределах одного и того же логического диска – длительной операции копирования удаётся избежать.

Максимальный размер файла видео, который можно записать, определяется реализацией Video For Windows и составляет 2 Гб. Однако, к сожалению, ни Video For Windows, ни Video Recorder не контролируют размер этого файла при записи (мы надеемся, что в следующей версии Video Recorder этот недостаток будет устранён), и, если файл превысит максимальный размер, прочитать его будет невозможно.

Размер файла определяется размером кадра, частотой кадров, временем записи и установленным компрессором видео. Например, для видео 512 х 512 х 8 бит без сжатия (= 256 Кб) и без звука, максимальное время записи при скорости 25 к/сек составляет не более 5 минут, при 12.5 к/сек – 10 минут и т.д., при 1 к/сек – около 2 часов.

Можно осуществлять захват одиночного кадра или видео (автоматически или по кадрам), предварительно выбрав режим захвата.


Захват одиночного кадра.

Для захвата одиночных кадров кнопка [image] должна быть нажата. При этом кнопки [image] и [image] становятся недоступны.

При нажатии кнопки [image] текущий кадр захватывается. После этого появляется диалоговое окно "Переименование/перемещение захваченного клипа", аналогичное стандартному диалогу сохранения файлов.


Захват видео по кадрам.

Для захвата видео по кадрам кнопка [image] должна быть нажата. Кнопка [image] должна быть отжата (автоматический захват отменён). Кнопка [image] становится недоступной.

При нажатии кнопки [image], она заменяется на две кнопки – [image] и [image] , при этом кнопка [image] становится недоступной.

Каждый раз когда нажимается кнопка [image], происходит захват очередного кадра. Внизу панели управления появляется надпись "Записано кадров: <количество захваченных кадров>".

Захват заканчивается при нажатии на кнопку [image]. После этого появляется диалоговое окно "Переименование/перемещение захваченного клипа", аналогичное стандартному диалогу сохранения файлов. Захваченные кадры будут сохранены также в виде клипа (файл видео).


Параметры захвата видео.

После нажатия кнопки [image] появится диалоговое окно "Параметры Video Recorder" выберите закладку "Захват".

Можно установить некоторые параметры захвата видео, которые изменяются достаточно редко.

Файл видео содержит участок фиксированной длины в котором записывается индексы кадров, поэтому Video For Windows необходимо предварительно знать, сколько максимально может быть кадров. Чем больше заданное значение – тем больше длина файла при прочих равных условиях. Значение по умолчанию – 34952.

Если требуемая скорость ввода не может быть обеспечена, некоторые кадры будут пропущены. Будет также сгенерирована ошибка, если больше чем указанный процент кадров было пропущено.

При захвате видео, если аудио тоже захватывается, процедура может быть синхронизирована по аудио, однако, это может увеличить процент пропущенных кадров.

Обычно, захват прекращается по нажатию клавиши ESC на клавиатуре. Дополнительно для этого могут использоваться левая и правая кнопки мыши.


Аналогичные темы

Смотри также


Заголовок

VideoRecorder


Строка навигации

Номе| Содержание | ТАНА


VideoRecorder

Нет справки

Справка по этой теме отсутствует.


Использование схем

VideoRecorder

Использование схем.

Диалоги "Видео Формат" и "Видео Источник" имеют панель инструментов для работы со схемами.

Схемой называется совокупность параметров устройства, однозначно определяющая его работу. Схемы устанавливаются раздельно для каждого из видеовходов устройства, однако существует режим, при котором для всех видеовходов устанавливается одна и та же схема (Based Source Mode).

Программа автоматически сохраняет в конце сеанса работы и восстанавливает в начале следующего сеанса текущие схемы для всех видеовходов устройства. Дополнительно Вы можете запоминать текущую схему под уникальным именем и впоследствии восстанавливать её, что должно избавить Вас от установки необходимых параметров каждый раз вручную.

Доступ к схемам предоставляет панель инструментов.

Выбрать нужный видеовход устройства.

Установить схему для выбранного видеовхода.

Сохранить текущие параметры устройства в виде схемы. Появится диалог, в котором у Вас будет запрошено имя схемы.

Удалить ненужную схему. Появится диалог, в котором Вы можете это делать.

Получить доступ к специальным параметрам, если это разрешено конфигурацией. Появится соответствующий диалог.

Установить одну и ту же схему для всех входов (Based Source Mode). Схема для текущего видеовхода будет установлена для остальных.

Ниже приведены диалоги для сохранения и удаления схем.


Специальные элементы управления

VideoRecorder

Специальные элементы управления.

Для ввода необходимых параметров используются управляющие элементы, которые могут показаться Вам незнакомыми.

Поле ввода со стрелками позволяет вводить числовую величину, не набирая её на клавиатуре. От стандартного отличается наличием перекладины между стрелками, позволяющей “протягивать” значение с помощью мыши.

Нажатие с помощью мыши на стрелку вверх увеличивает числовую величину, а на стрелку вниз - уменьшает. Если кнопка мыши удерживается нажатой - изменение продолжается.

Нажатие с помощью мыши на перекладину - при этом курсор такой, как показан - и перемещение мыши с удержанием нажатой кнопки вверх - увеличивает, а вниз - уменьшает величину.

Клавиши со стрелками вверх и вниз, а также PgUp и PgDn на клавиатуре также позволяют менять числовую величину, но при этом фокус должен находиться на поле ввода. Таким способом удобно подбирать какой-либо параметр, например, уровни чёрного и белого.


Автозахват видео

Синхронизация МСI устройства

Установка таймера захвата видео

Установка скорости захвата видео

Захват видео по кадрам

Захват одиночного кадра

Выбор режима захвата

Захват


Выбор формата видео

Выбор параметров источника видео


Мониторинг

Параметры мониторинга


Палитра

Выбор параметров источника видео


Параметры аудио

Выбор параметров источника видео


Параметры файлов видео

Установка специальных параметров


Параметры источника видео

Выбор формата видео


Параметры мониторинга

Установка режима мониторинга


Параметры сжатия

Захват


Запуск программы

Установка режима мониторинга


Выбор режима захвата

Захват

Автоматический захват видео

Захват видео по кадрам

Захват одиночного кадра


Синхронизация

Захват


Параметры Video Recorder'a

Параметры файлов видео

Параметры захвата видео

Параметры мониторинга


Установка скорости видео

Автоматический захват видео

Захват видео по кадрам


Установка времени видео

Автоматический захват видео


Захват одиночного кадра

Автоматический захват видео

Захват видео по кадрам

Выбор режима захвата

Захват


Захват

Автоматический захват видео

Захват видео по кадрам

Захват одиночного кадра

Выбор режима захвата


Захват видео по кадрам

Автоматический захват видео

Захват одиночного кадра

Выбор режима захвата

Захват


Параметры захвата видео

Автоматический захват видео

Захват видео по кадрам

Захват одиночного кадра

Выбор режима захвата

Захват


print1

Справка по Video Recorder

© OOO"ТАНА" 2000г

Содержание

Назначение программы | 4
Особенности работы с видео | 4
Запуск программы и выбор устройства | 5
Установка режима мониторинга | 6
Синхронизация MCI устройства | 6
Установка параметров аудио | 6
Выбор параметров источника видео | 7
Выбор формата видео | 8
Установка параметров сжатия | 8
Работа с палитрой | 9
Установка скорости захвата видео | 10
Установка таймера захвата видео | 10
Выбор режима захвата | 10
Захват | 11
Автоматический захват видео Захват видео по кадрам Захват одиночного кадра | 11 11 12
Установка параметров Video Recorder'a | 13
Параметры файлов видео Параметры захвата видео Параметры мониторинга | 13 13 14
Специальные элементы управления | 15
Специальные элементы управления | 16
ТАНА | 17

Назначение программы.

Video Recorder предназначен для записи видео, используя установленные в системе драйверы Video Capture Devices, отвечающие спецификации Video For Windows. С помощью этой программы можно записывать как непрерывное видео, так и одиночные кадры. Video Recorder записывает видео непосредственно в файл, расположенный на жёстком диске компьютера.

Video Recorder является самостоятельной программой, однако может работать под управлением других программных продуктов выпускаемых компанией "TAHA".

Особенности работы с видео.

Video Recorder записывает видео непосредственно в файл, расположенный на жёстком диске компьютера. Поскольку этот файл может быть очень большим (до 2 Гб), предприняты меры для исключения лишних операций копирования.

Video Recorder постоянно держит заранее подготовленный к захвату файл, чтобы уменьшить время, необходимое для инициализации операции захвата. Этот файл имеет автоматически сгенерированное специальное имя. После успешного захвата Video Recorder предлагает просто переименовать этот файл. Если переименование происходит в пределах одного и того же логического диска – длительной операции копирования удаётся избежать.

Максимальный размер файла видео, который можно записать, определяется реализацией Video For Windows и составляет 2 Гб. Однако, к сожалению, ни Video For Windows, ни Video Recorder не контролируют размер этого файла при записи (мы надеемся, что в следующей версии Video Recorder этот недостаток будет устранён), и, если файл превысит максимальный размер, прочитать его будет невозможно.

Размер файла определяется размером кадра, частотой кадров, временем записи и установленным компрессором видео. Например, для видео 512 х 512 х 8 бит без сжатия (= 256 Кб) и без звука, максимальное время записи при скорости 25 к/сек составляет не более 5 минут, при 12.5 к/сек – 10 минут и т.д., при 1 к/сек – около 2 часов.

Запуск программы и выбор устройства.

Video Recorder можно запустить как самостоятельное приложение (т.е. также как и любое другое приложение Windows) или под управлением другого программного обеспечения TANA (смотрите соответствующую документацию по этому программному обеспечению). В последнем случае заголовок окна Video Recorder имеет форму:

Video Recorder for <Имя_управляющей_программы>.

Окно Video Recorder представляет собой монитор текущего видео на входе (если, конечно, устройство ввода видео правильно установлено и выбрано).

Окно также имеет панель управления, которую можно расположить как больше нравится: прикрепить слева или справа, а также открепить и расположить отдельно. Окно Video Recorder (также как и панель управления) запоминает своё расположение на экране от сеанса к сеансу.

Если в системе установлено несколько устройств захвата видео, то нужное можно выбрать с помощью раскрывающегося списка на панели управления Video Recorder. При старте Video Recorder автоматически подключает устройство, выбранное в предыдущем сеансе.

Для выхода из Video Recorder можно либо закрыть его окно как обычно, либо нажать кнопку [image] на панели управления.


print2

Установка режима мониторинга.

Некоторые устройства захвата видео поддерживают режим непосредственного отображения видео на дисплее компьютера (Overlay mode). В этом случае вычислительные ресурсы системы используются минимально, а частота кадров отображения видео на дисплее компьютера равна частоте кадров видео на входе. Для всех остальных устройств, не поддерживающих данный режим, мониторинг осуществляется за счёт вычислительных ресурсов системы, и частота кадров отображения видео обычно несколько меньше.

Если установлено устройство с возможностью непосредственного отображения видео (Overlay mode), то данная кнопка на панели управления разрешена. Если кнопка нажата, то режим непосредственного отображения видео включен (кнопка имеет независимую фиксацию).

Если при нажатии данной кнопки курсор мыши расположен в районе стрелки вниз, то будет выведен диалог установки параметров режима непосредственного отображения, если драйвер устройства ввода видео поддерживает такой диалог.

Синхронизация MCI устройства.

В системе может быть установлено устройство MCI (Multimedia Control Interface), управляющее источником видео, то такое устройство можно синхронизировать с операцией захвата. В частности, это может быть устройство управления видеомагнитофоном, и можно установить начало и конец фрагмента для записи.

Если в системе установлено MCI устройство типа VCR или Videodisk, то данная кнопка разрешена. Если кнопка нажата, то захват видео будет синхронизирован с устройством MCI (кнопка имеет независимую фиксацию).

Установка параметров аудио.

Если в системе имеется устройство ввода аудио (звуковая карта), то эта кнопка разрешена. Если кнопка нажата, то вместе с видео будет записываться также и звук (кнопка имеет независимую фиксацию).

Если при нажатии кнопки [image] курсор мыши расположен в районе стрелки вниз, то будет выведен стандартный диалог выбора формата записи аудио.

В диалоговом окне "Выбор звука" выберите Название из ниспадающего списка, оно будет определять схему настроек. Выберите Формат и Атрибуты (частоту, количество бит, моно или стерео, скорость) записи аудио из ниспадающего списка, которые позволяет установить выбранная схема настроек. Для ввода нажмите ОК, для отказа нажмите "Отмена".

Выбор параметров источника видео.

Драйверы устройств ввода видео обычно поддерживают несколько встроенных диалогов. Диалог "Видео источник" – один из них, получаемый при использовании драйвера DTOL Video Capture Device Driver для устройства, соответствующего стандарту DTOL ( Data Translation's Open Layers ).

Обычно в этом диалоге можно установить такие параметры как яркость, контраст, цветовая насыщенность, иными словами уровни черного и белого, усиление, смещение и опора.

Если диалог поддерживается драйвером устройства ввода видео, то кнопка [image] разрешена. При нажатии на кнопку указанный диалог будет выведен.

Выбор формата видео.

Драйверы устройств ввода видео обычно поддерживают несколько встроенных диалогов. Диалог "Видео формат" - один из них, получаемый при использовании драйвера DTOL Video Capture Device Driver для устройства, соответствующего стандарту DTOL ( Data Translation's Open Layers ).

Обычно в этом диалоге можно установить такие параметры как Высота и Ширина кадра. Высота измеряется в количестве линий, а ширина в пикселах. Параметры Лево и Верх означают отступы слева и сверху в активной области кадра (активная область кадра задается в дополнительных параметрах).

Параметр Аспект определяет изменение соотношения вертикального и горизонтального размера и регулируется вставкой или удалением строк. Если Аспект равен 2, то каждая строка повторяется; если Аспект равен 0.5 , то каждая вторая строка пропускается.

Параметр Поворот определяет поворот кадра на определенный угол и измеряется в градусах. При выборе Зеркало получим зеркальное отражение кадра. Последовательность операций следующая: Аспект, Поворот, Зеркало.

Если диалог поддерживается драйвером устройства ввода видео, то кнопка [image] разрешена. При нажатии на кнопку указанный диалог будет выведен.

Установка параметров сжатия видео.

В системе может быть установлен программный или аппаратно-программный компрессор видео. Такой компрессор может быть также встроен в оборудование устройства захвата видео. При пользовании компрессором необходимо помнить, что сжатие видео обычно осуществляется с потерей качества, зависящей от степени сжатия. Кроме того программное сжатие может занять существенное время, так что скорость ввода может существенно упасть.

При нажатии на данную кнопку будет выведен стандартный диалог выбора компрессора и установки параметров сжатия.

Программу сжатия выберите из ниспадающего списка.

Качество сжатия установите с помощью движка, по умолчанию для каждой программы предлагается определенная величина.

Установите через сколько кадров должен идти опорный кадр, если число не установлено, то опорным будет принят первый кадр. Это требуется для того чтобы ошибка при сжатии не накапливалась. Например, опорный кадр каждые 15 кадров. В начале опорный - 1-й кадр, он и записывается без изменений. Далее сжимается и записывается разница между кадрами, 15-й кадр записывается без изменений и т.д. Таким образом ошибка не накапливается.

Так же для каждой программы сжатия можно посмотреть её настройки с помощью кнопки.


print3

Работа с палитрой.

Если драйвер устройства ввода видео поддерживает работу с палитрой, то данная кнопка разрешена.

Нажатие на неё выводит ниспадающее меню, с помощью которого можно сохранить текущую палитру, загрузить предварительно сохранённую палитру, а также захватить палитру, - т.е. оптимизировать палитру под конкретный видеосигнал.

В первых двух случаях выводятся стандартные диалоги открытия и сохранения файлов.

В последнем случае выводится диалог захвата палитры, в котором можно сделать это автоматически по всем кадрам или по конкретно указанным кадрам.

После нажатия кнопки "Старт" вместо двух кнопок появляется одна "Закончить". Внизу окна будет фиксироваться количество захваченных кадров.

Если захват палитры производить по выбранным кадрам, то в место кнопки "Старт" появится кнопка "Кадр!". Количество нажатий на кнопку равно количеству выбранных кадров.

Установка скорости захвата видео.

Захват видео можно осуществлять автоматически с определённой скоростью или по кадрам.

Для автоматического захвата данная кнопка с независимой фиксацией должна быть нажата. При этом поле ввода скорости захвата разрешено, и можно установить желаемую скорость (в кадрах в секунду). Заметим, что поддерживаются скорости ниже одного кадра в секунду, например 0.1 к/сек означает один кадр в 10 секунд.

Для ввода видео по кадрам данная кнопка должна быть отжата (поле ввода скорости захвата при этом запрещено). В этом режиме захват очередного кадра осуществляется при нажатии кнопки [image] Снимок, и захват продолжается до тех пор пока не будет нажата кнопка [image] Стоп.

Установка таймера захвата видео.

При автоматическом режиме захвата видео можно установить таймер максимального времени захвата.

Если данная кнопка с независимой фиксацией нажата, то поле ввода максимального времени захвата видео разрешено, и можно установить желаемое значение. По истечении указанного времени операция захвата будет завершена (захват можно закончить также досрочно обычным образом).

Выбор режима захвата.

Можно захватывать не только видео (автоматически или по кадрам), но и одиночные кадры.

Данные кнопки с зависимой фиксацией переключают режим захвата видео и режим захвата одиночных кадров соответственно.

Если нажата кнопка [image] , то установлен режим захвата видео, а если нажата кнопка [image] , то - режим захвата одиночного кадра.

Режим захвата видео по кадрам обычно используется для сокращения длины видео клипа, путем выбора самых важных кадров.

Захват.

Video Recorder записывает видео непосредственно в файл, расположенный на жёстком диске компьютера. Поскольку этот файл может быть очень большим (до 2 Гб), предприняты меры для исключения лишних операций копирования.

Поддерживается заранее подготовленный к захвату файл (см. Параметры файлов видео), чтобы уменьшить время, необходимое для инициализации операции захвата. Этот файл имеет автоматически сгенерированное специальное имя. После успешного захвата Video Recorder предлагает просто переименовать этот файл. Если переименование происходит в пределах одного и того же логического диска – длительной операции копирования удаётся избежать.

Максимальный размер файла видео, который можно записать, определяется реализацией Video For Windows и составляет 2 Гб. Однако, к сожалению, ни Video For Windows, ни Video Recorder не контролируют размер этого файла при записи (мы надеемся, что в следующей версии Video Recorder этот недостаток будет устранён), и, если файл превысит максимальный размер, прочитать его будет невозможно.

Размер файла определяется размером кадра, частотой кадров, временем записи и установленным компрессором видео. Например, для видео 512 х 512 х 8 бит без сжатия (= 256 Кб) и без звука, максимальное время записи при скорости 25 к/сек составляет не более 5 минут, при 12.5 к/сек – 10 минут и т.д., при 1 к/сек – около 2 часов.

Можно осуществлять захват одиночного кадра или видео (автоматически или по кадрам), предварительно выбрав режим захвата.

Автоматический захват видео.

Для захвата видео кнопка [image] должна быть нажата. Также должна быть нажата кнопка [image] и установлена желаемая скорость ввода в соответствующем поле. Кроме того может быть нажата кнопка [image] и установлено максимальное время захвата видео.

При нажатии кнопки [image] захват начнётся немедленно (максимальная задержка не превышает 1 секунды). Если захват синхронизирован с MCI – устройством, то последнее соответствующим образом позиционируется, и захват автоматически начинается с указанного места.

Внизу панели управления указывается :

"Длительность: <время проигрывания клипа>с

Кадров:<количество кадров в клипе>(пропущено<количество пропущенных кадров>)

(<скорость проигрывания клипа>кадров/с)".

После того как захват завершен появляется диалоговое окно "Переименование/перемещение захваченного клипа", аналогичное стандартному диалогу сохранения файлов.

Захват заканчивается при нажатии клавиши ESC на клавиатуре или по истечении максимального времени захвата, предварительно установленного таймером захвата видео.

Захват видео по кадрам.

Для захвата видео по кадрам кнопка [image] должна быть нажата. Кнопка [image] должна быть отжата (автоматический захват отменён). Кнопка [image] становится недоступной.

При нажатии кнопки [image], она заменяется на две кнопки – [image] и [image] , при этом кнопка [image] становится недоступной.

Каждый раз когда нажимается кнопка [image], происходит захват очередного кадра. Внизу панели управления появляется надпись "Записано кадров: <количество захваченных кадров>".

Захват заканчивается при нажатии на кнопку [image]. После этого появляется диалоговое окно "Переименование/перемещение захваченного клипа", аналогичное стандартному диалогу сохранения файлов. Захваченные кадры будут сохранены также в виде клипа (файл видео).

Захват одиночного кадра.

Для захвата одиночных кадров кнопка [image] должна быть нажата. При этом кнопки [image] и [image] становятся недоступны.

При нажатии кнопки [image] текущий кадр захватывается. После этого появляется диалоговое окно "Переименование/перемещение захваченного клипа", аналогичное стандартному диалогу сохранения файлов.


print4

Установка параметров Video Recorderа.

Video Recorder позволяет установить ряд специальных параметров для настройки и оптимизации.

Параметры файлов видео, захвата видео и мониторинга.

Параметры файлов видео.

После нажатия кнопки [image] появится диалоговое окно "Параметры Video Recorder" выберите закладку "Файл".

Можно установить рабочий каталог, в который будут помещаться файлы захваченного видео. Указанный каталог должен существовать. По умолчанию (при первом старте) рабочим каталогом считается каталог, в котором находится сам Video Recorder. Важно правильно выбрать каталог, чтобы избежать лишних операций копирования.

Префикс представляет из себя первые три буквы в имени файла, а текущий номер - последние четыре цифры в имени файла.

В заголовке окна видео клипа перед именем файла будет стоять значок [image] .

Если дисковая подсистема компьютера слишком медленная, можно попробовать предварительный захват пространства на диске – он будет осуществляться автоматически. Иногда таким способом можно увеличить скорость ввода. Если предварительный захват пространства не требуется – установите 0 в соответствующем поле ввода.

Параметры захвата видео.

После нажатия кнопки [image] появится диалоговое окно "Параметры Video Recorder" выберите закладку "Захват".

Можно установить некоторые параметры захвата видео, которые изменяются достаточно редко.

Файл видео содержит участок фиксированной длины в котором записывается индексы кадров, поэтому Video For Windows необходимо предварительно знать, сколько максимально может быть кадров. Чем больше заданное значение – тем больше длина файла при прочих равных условиях. Значение по умолчанию – 34952.

Если требуемая скорость ввода не может быть обеспечена, некоторые кадры будут пропущены. Будет также сгенерирована ошибка, если больше чем указанный процент кадров было пропущено.

При захвате видео, если аудио тоже захватывается, процедура может быть синхронизирована по аудио, однако, это может увеличить процент пропущенных кадров.

Обычно, захват прекращается по нажатию клавиши ESC на клавиатуре. Дополнительно для этого могут использоваться левая и правая кнопки мыши.

Параметры мониторинга.

После нажатия кнопки [image] появится диалоговое окно "Параметры Video Recorder" выберите закладку "Монитор".

Цвет фона окна Video Recorder можно установить по желанию (в % серого).

Можно также включить режим, при котором размер окна Video Recorder будет автоматически отслеживать размер видео (в данной версии не реализовано).

Использование схем.

Диалоги "Видео Формат" и "Видео Источник" имеют панель инструментов для работы со схемами.

Схемой называется совокупность параметров устройства, однозначно определяющая его работу. Схемы устанавливаются раздельно для каждого из видеовходов устройства, однако существует режим, при котором для всех видеовходов устанавливается одна и та же схема (Based Source Mode).

Программа автоматически сохраняет в конце сеанса работы и восстанавливает в начале следующего сеанса текущие схемы для всех видеовходов устройства. Дополнительно Вы можете запоминать текущую схему под уникальным именем и впоследствии восстанавливать её, что должно избавить Вас от установки необходимых параметров каждый раз вручную.

Доступ к схемам предоставляет панель инструментов.

Выбрать нужный видеовход устройства.

Установить схему для выбранного видеовхода.

Сохранить текущие параметры устройства в виде схемы. Появится диалог, в котором у Вас будет запрошено имя схемы.

Удалить ненужную схему. Появится диалог, в котором Вы можете это делать.

Получить доступ к специальным параметрам, если это разрешено конфигурацией. Появится соответствующий диалог.

Установить одну и ту же схему для всех входов (Based Source Mode). Схема для текущего видеовхода будет установлена для остальных.

Ниже приведены диалоги для сохранения и удаления схем.

Специальные элементы управления.

Для ввода необходимых параметров используются управляющие элементы, которые могут показаться Вам незнакомыми.

Поле ввода со стрелками позволяет вводить числовую величину, не набирая её на клавиатуре. От стандартного отличается наличием перекладины между стрелками, позволяющей “протягивать” значение с помощью мыши.

Нажатие с помощью мыши на стрелку вверх увеличивает числовую величину, а на стрелку вниз - уменьшает. Если кнопка мыши удерживается нажатой - изменение продолжается.

Нажатие с помощью мыши на перекладину - при этом курсор такой, как показан - и перемещение мыши с удержанием нажатой кнопки вверх - увеличивает, а вниз - уменьшает величину.

Клавиши со стрелками вверх и вниз, а также PgUp и PgDn на клавиатуре также позволяют менять числовую величину, но при этом фокус должен находиться на поле ввода. Таким способом удобно подбирать какой-либо параметр, например, уровни чёрного и белого.

TANA Logo Компания"ТАНА"
medical imaging systems
Адрес: | г. Москва, Староваганьковский пер., д.15, офис 14
Тел.: | (095) 202-1212
Факс: | (095) 202-0845
E-mail: | tana-com@space.ru
WWW: | http://www.tana.ru

Лицензия на производство, реализацию и техническое обслуживание

медицинской техники №42/2000-1151-1150 от 24.05.2000г.